
Page 0 of 13 
 

 

  

 

Microsoft Access Objects 
 

IT Department 

Database Systems 1 (IT215) 

Fall 2025 – 2026 

Lecturer: Soma Soleimanzadeh 

Reference – Official website of Microsoft Support (https://support.microsoft.com/en-us) 

https://support.microsoft.com/en-us


Page 1 of 13 
 

 Microsoft Access (Practical) 

 

Create a database 

1. Open Access. 

• If Access is already open, select File > New. 

2. Select Blank database. 

 

3. Enter a name for the database, select a location, and then 

select Create. 

• If needed, select Enable content in the yellow 

message bar when the database opens. 

 

Import data from Excel 

1. Open the Excel workbook, make sure each column has a heading and a consistent data 

type, and then select the range of data. 

2. Select External Data > New Data Source > From File > Excel. 

3. Select Browse to find the Excel file, accept the default values, and then click OK. 

4. Select Does the first row of your data contain column headings?, and then click Next. 

5. Complete the rest of the wizard screens, and select Finish. 

 

 

 

 

 

 

Creating Database in Access 
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When you create a table with Table Design, you can be more deliberate about designing your 

database, set field types, create a lookup list, and create a foreign key to pair with your primary 

key. 

Create a Table in a Database 

When you open a new, blank database, Access automatically creates an empty table. To customize 

that table, start defining your fields and adding data. 

Rename a table in a database 

Table1 is the default name of the first table in a new database. It’s a good idea to name the table 

something more meaningful. 

1. On the Quick Access Toolbar, select Save  

2. In the Table name box, enter a descriptive name. 

Add a table to a database 

Add more tables to a database, if you need them. 

1. On the Create tab, select Table. 

 

• Access adds a new table with the name Table<#>, where <#> is the next sequential, 

unused number. 

2. Rename the table. 

Adding fields (columns), setting their data types and entering data in tables 

Each table in MS Access has two views; Design View and Datasheet View. 

• Datasheet View: When you open a table, Access displays the table in Datasheet 

view. In this view, you can enter data into the table manually. 

• Design View: In Design view, you can add fields of the table, setting fields’ name 

and data types. You can also change or remove the primary key, or 

set the primary key for a table that doesn't already have one.  

Tables 
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Save a Table 

• Before you close your database, to avoid losing the work you’ve done and the data 

you’ve entered, be sure to save your table. When you try to close the database, if 

you haven’t saved your work on a table, Access prompts you to save it. Or, at any 

time, select .  

Relationships Between Tables 

The power of a relational database lies in combining data across tables. To do that, you first need 

to establish relationships between your tables. Then, put Access to work to combine data in queries, 

forms, and reports. 

To see all existing relationships defined for a database, open an Access database, go to the 

Database Tools tab, and select Relationships. 

 

 

 

The lines in the Relationships view indicate connections between the tables. In the following 

image, the table on the left is the parent table. The table on the right is the child table. The line 

between them connects the fields used to match data. The number 1 at one end of the connecting 

line and the ∞ symbol at the other end indicate that this is a one-to-many relationship. 

 

 

 

 

 

 

 

 

 

 



Page 4 of 13 
 

Types of relationships between tables 

There are three types of relationships between tables: 

• One-to-one: When each item in each table only appears once. For example, each employee 

can have only one company car to use.  

• One-to-many: When one item in one table can have a relationship to multiple items in 

another table. For example, each purchase order can include multiple products. 

• Many-to-many: When one or more items in one table can have a relationship to one or 

more items in another table. For example, each order can have multiple products, and each 

product can appear on many orders. 

 

Build/Edit Relationships Between Tables 

1. Select Database Tools > Relationships. 

2. To build a relationship between two tables, drag the parent table's primary key to the child 

table's foreign key. In case, there is already a relationship, select the line connecting two 

related tables. 

 

3. On the Design tab, select Edit Relationships. 

 

• Table/Query is the parent table. 

• Related Table/Query is the child table. 

 

 

 

 

 

 

 

 

 

 

 

4. To change the fields that connect the tables, select a different field below each table shown. 

In this example, the ID field in the Customers table connects to the Customer ID field in 

the Orders table. 

5. Change the way Access synchronizes your data between tables. 

• Enforce Referential Integrity: To prevent invalid data and to keep 

references in sync across table relationships, select this. 
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• Cascade Update Related Fields: To make sure that data in related fields is 

updated in all the related tables, select this. 

• Cascade Delete Related Records: The decision to select this depends on 

whether you need to retain records in some tables even though they might 

be deleted from other tables. 

 

6. To change the relationship between the tables from an inner join to an outer join, select the 

Join Type button.  

Delete a table relationship 

To remove a table relationship: 

1. Select Database Tools > Relationships. 

2. Select the line connecting the two related tables. 

3. Select the Delete key. If you’re prompted to verify that you want to delete the relationship, 

select Yes. 
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A form in Access is a database object that you can use to create a user interface for a database 

application. A "bound" form is one that is directly connected to a data source such as a table or 

query, and can be used to enter, edit, or display data from that data source. Alternatively, you can 

create an "unbound" form that does not link directly to a data source, but which still contains 

command buttons, labels, or other controls that you need to operate your application. 

Forms in Access are like display cases in stores that make it easier to view or get the items that 

you want. Since forms are objects through which you or other users can add, edit, or display the 

data stored in your Access desktop database, the design of your form is an important aspect. If 

your Access desktop database is going to be used by multiple users, well-designed forms is 

essential for efficiency and data entry accuracy. 

 

Create a Form from an Existing Table or Query in Access 

1. In the Navigation Pane, click the table or query that contains the data you want to see on 

your form. 

2. On the Create tab, in the Forms group, click Form. 

 

 

 

 

 

Access creates the form and displays it in Layout view. In Layout view, you can make design 

changes to the form while it is displaying data. For example, you can adjust the size of the text 

boxes to fit the data, if necessary. 

Layout view: Layout view is the most intuitive view to use for form modification, and it can be 

used for almost all the changes that you would want to make to a form in Access. 

However, you can also change the form design in this view. Because you can see the data while 

you are modifying the form, this is a very useful view for setting the size of controls or performing 

almost any other task that affects the appearance and usability of the form. 

Forms 
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Design view: Design view gives you a more detailed view of the structure of your form. You can 

see the Header, Detail, and Footer sections for the form. The form is not actually running when it 

is shown in Design view. Therefore, you cannot see the underlying data while you are making 

design changes. However, there are certain tasks that you can perform more easily in Design view 

than in Layout view. You can: 

• Add a wider variety of controls to your form, such as bound object frames, page breaks, 

and charts. 

• Edit text box control sources in the text boxes themselves, without using the property sheet. 

• Resize form sections, such as the Form Header or the Detail section. 

• Change certain form properties that cannot be changed in Layout view. 
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Add a List Box or Combo Box 

When entering data on forms in Access desktop databases, it can be quicker and easier to select a 

value from a list than to remember a value to type. A list of choices also helps ensure that the value 

entered in a field is appropriate. A list control can connect to existing data, or it can display fixed 

values that you enter when you create the control. 

List box: The list box control displays a list of values or choices. The user is limited to the choices 

given in the list box; it is not possible to type a value into a list box. 

 

 

 

Combo box: The combo box control provides a more compact way to present a list of choices; the 

list is hidden until you click the drop-down arrow. A combo box also gives you the ability to enter 

a value that is not in the list. In this way, the combo box control combines the features of a text 

box and a list box. 

 

 

 

 

 

 

Create a List Box or a Combo Box by Using a Wizard 

1. Right-click the form in the Navigation Pane, and then click Design View. 

2. On the Form Design tab, in the Controls group, ensure that Use Control Wizards is 

selected. 

3. Click either the List Box or the Combo Box tool. 

4. On the form, click where you want to place the list box or combo box. 

• Depending on your choice, the List Box Wizard or the Combo Box Wizard starts. 

5. When the wizard asks how you want to get the values for the control, do one of the 

following:  

• If you want to display the current data from a record source, click I want the list 

box/combo box to look up the values in a table or query.  
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• If you want to display a fixed list of values that will seldom change, click I will 

type in the values that I want.  

• If you want the control to perform a find operation, rather than serve as a data entry 

tool, click Find a record on my form based on the value I selected in my list 

box/combo box. This creates an unbound control with an embedded macro that 

performs a find operation based on the value the user enters. 

6. Follow the instructions for specifying how the values will appear. 

7. If you choose one of the first two options on the first page of the wizard, the wizard asks 

what you want Access to do when you select a value. Do one of the following:  

• To create an unbound control, click Remember the value for later use. This means 

that Access will hold the selected value until the user changes it or closes the form, 

but it will not write the value to a table.  

• To create a bound control, click Store that value in this field, and then select the 

field you want to bind the control to. 

8. Click Next and type a label for the control. This label will be displayed next to the control. 

9. Click Finish. 

 

Use a Command Button to Start an Action or a Series of Actions 

You use a command button on an Access form to start an action or a set of actions. For example, 

you can create a command button that opens another form. To make a command button perform 

an action, you write a macro or event procedure and attach it to the command button's On Click 

property. You can also embed a macro directly into the On Click property of the command button. 

 

Add a Command Button to a Form by Using a Wizard 

By using the Command Button Wizard, you can quickly create command buttons that do a variety 

of tasks. 

1. Right-click the form in the Navigation Pane, and then click Design View  on the 

shortcut menu. 

2. On the Form Design tab, in the Controls group, ensure that Use Control Wizards is 

selected. 

3. On the Form Design tab, in the Controls group, click Button.  
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4. In the design grid, click where you want the command button to be inserted. The Command 

Button Wizard starts. 

5. Follow the directions in the wizard. On the last page, click Finish. 
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Using a query makes it easier to view, add, delete, or change data in your Access database. Some 

other reasons for using queries: 

• Find specific quickly data by filtering on specific criteria (conditions) 

• Calculate or summarize data 

• Automate data management tasks, such as reviewing the most current data on a recurring 

basis. 

 

 

 

 

 

 

 

 

Create a Select Query 

If you want to review data from only certain fields in a table, or review data from multiple tables 

simultaneously or maybe just see the data based on certain criteria, a select query type would be 

your choice.  

Review data from select fields 

For example, if your database has a table with a lot of information about products and you want 

to review a list of products and their prices, here’s how you’d create a select query to return just 

the product names and the respective price: 

1. Open the database and on the Create tab, click Query Design. 

 

 

 

 

2. Switch to SQL view to write the SELECT query in SQL. 

 

 

 

 

Queries 



Page 12 of 13 
 

3. In SQL editor, you can write any query.  

 

 

 

4. On the Query Design tab, click Run. The query runs and displays the query output. 

 

 

 

 

 

5. Save the query and rename it. All saved queries are available under the Queries category 

in the navigation pane. 
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Before you share your database with others, put the information in a format that’s easy to 

understand. View, format, and summarize the information in your database with reports. 

1. In the Navigation pane, select a record source. The record source of a report might be a 

table or a named query. It must contain all of the rows and columns of data that you want 

to include in the report. 

2. On the Create tab, select the report tool you want to use and, to create the report, follow 

any instructions. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Reports 


